New Stripe Plugin

Bastiaan.C
Bastiaan.C
Offline
0
When receiving a credit Card Payment, the updated Stripe plugin will not automatically register the payment in invoice manager anymore. I will only receive an email from Stripe and the rest is not functional anymore :-(

Please help!

Thank you :-)
Responses (41)
  • Accepted Answer

    Tuesday, October 02 2018, 01:41 PM - #Permalink
    0
    when you say the "updated" plugin, which version you mean?
    it did not happen before?
    The reply is currently minimized Show
  • Accepted Answer

    Bastiaan.C
    Bastiaan.C
    Offline
    Tuesday, October 02 2018, 01:44 PM - #Permalink
    0
    plg_payment_stripe_1.1.1
    is working > it will update the payment for the invoice and it will show no error for the customer
    By the way. I use php 7.2.10 but it should make no difference
    The reply is currently minimized Show
  • Accepted Answer

    Bastiaan.C
    Bastiaan.C
    Offline
    Wednesday, October 03 2018, 01:48 PM - #Permalink
    0
    Please see the attachment. The payment goes through (paid to stripe)
    However > It won't complete in invoice manager / expense manager (mark as paid)

    People get confused about this and pay twice
    The reply is currently minimized Show
  • Accepted Answer

    Bastiaan.C
    Bastiaan.C
    Offline
    Wednesday, October 03 2018, 01:49 PM - #Permalink
    0
    Please see the attachment. The payment goes through (paid to stripe)
    However > It won't complete in invoice manager / expense manager (mark as paid)

    People get confused about this and pay twice
    Attachments:
    The reply is currently minimized Show
  • Accepted Answer

    Wednesday, October 03 2018, 02:09 PM - #Permalink
    0
    hello

    I don't understand your messages... you say "is working > it will update the payment for the invoice and it will show no error for the customer"

    but then you say it's not working..? is it working or not..?

    it was working on a previous version of our Stripe plugin and now it's not?
    The reply is currently minimized Show
  • Accepted Answer

    Bastiaan.C
    Bastiaan.C
    Offline
    Wednesday, October 03 2018, 02:23 PM - #Permalink
    0
    Ok,

    1. I have updated to your latest Stripe plugin "2.0.2"
    2. When a customer is paying with card (Stripe)
    3. The message as in the attachment is showing > Unknown column params in field list
    4. What happened?:
    - The customer paid with card
    - The payment was received by Stripe
    - The payment is not updated in Expense/Invoice manager
    - The message looks like an error and the customer wants to pay again
    5. This error does NOT occur if I use the Stripe plugin "1.1.1"
    6. PLEASE HELP
    7. PLEASE let me know if I was not clear explaining the issue
    1. that my customers have
    2. that I as an admin / Invoice Manager / Expense manager have

    Thanks for all you do

    Btw....here is a screenshot. I teh API version might be old?
    The reply is currently minimized Show
  • Accepted Answer

    Wednesday, October 03 2018, 02:26 PM - #Permalink
    0
    hello

    ok, that's what I was asking.

    yes, Version 2.0.2 uses the new API.

    well, if version 1.1.1 of the plugin, logically the first I will tell you is to switch back to that version, if it's not giving you problems. I can email you the file if necessary.
    The reply is currently minimized Show
  • Accepted Answer

    Bastiaan.C
    Bastiaan.C
    Offline
    Wednesday, October 03 2018, 02:27 PM - #Permalink
    0
    I think you are telling me:

    1. Upgrade Stripe API
    2. Install latest pluging
    3. Problems should be over?
    The reply is currently minimized Show
  • Accepted Answer

    Wednesday, October 03 2018, 02:29 PM - #Permalink
    0
    No. what I was saying is, if version 1.1.1 worked fine for you, then just keep using that version!

    the new version uses the new API, yes. So, if you want, you can try to update stripe version and try again. But again, if the old version worked for you, no need to switch.

    If you have something working, keep it, don't upgrade. that's what I'm saying. I can meanwhile investigate if it's a problem with the API version
    The reply is currently minimized Show
  • Accepted Answer

    Bastiaan.C
    Bastiaan.C
    Offline
    Wednesday, October 03 2018, 02:30 PM - #Permalink
    0
    Damn,

    1. I have upgraded the API
    2. I have updated the plugin
    The reply is currently minimized Show
  • Accepted Answer

    Wednesday, October 03 2018, 02:32 PM - #Permalink
    0
    and? does it work?
    The reply is currently minimized Show
  • Accepted Answer

    Bastiaan.C
    Bastiaan.C
    Offline
    Wednesday, October 03 2018, 02:34 PM - #Permalink
    0
    1. I will put it in test mode
    2. I will try https://stripe.com/docs/testing
    The reply is currently minimized Show
  • Accepted Answer

    Bastiaan.C
    Bastiaan.C
    Offline
    Wednesday, October 03 2018, 02:39 PM - #Permalink
    0
    No...It did not work!
    This is what happens:

    1. credit card filled in.
    2. Click on submit
    3. Green checkmark in button appears
    4. Waiting for redirect
    5. After redirect payment not completed to attached error
    The reply is currently minimized Show
  • Accepted Answer

    Bastiaan.C
    Bastiaan.C
    Offline
    Wednesday, October 03 2018, 02:40 PM - #Permalink
    0
    I think I will have to roll back API

    Install 1.1.1

    ???
    The reply is currently minimized Show
  • Accepted Answer

    Wednesday, October 03 2018, 02:42 PM - #Permalink
    0
    hello

    yes, for the 4th time :) please install version 1.1.1
    and let me know if that works
    The reply is currently minimized Show
  • Accepted Answer

    Bastiaan.C
    Bastiaan.C
    Offline
    Wednesday, October 03 2018, 02:47 PM - #Permalink
    0
    Ok, this is the situation now:

    1- API on Stripe is updated!
    2- plg_payment_stripe_1.1.1 is installed
    3- A test payment is done
    4- All has been done correct. However...only the error still shows up
    5. See attachment
    The reply is currently minimized Show
  • Accepted Answer

    Bastiaan.C
    Bastiaan.C
    Offline
    Wednesday, October 03 2018, 02:48 PM - #Permalink
    0
    I think the error: "The authorization code provided is not valid" is not relevant

    Still the old plugin seems to work on the new API
    The reply is currently minimized Show
  • Accepted Answer

    Wednesday, October 03 2018, 02:48 PM - #Permalink
    0
    ok. this is only the authorization code when you're not logged in.. we can remove this message if you send me FTP access.
    The reply is currently minimized Show
  • Accepted Answer

    Bastiaan.C
    Bastiaan.C
    Offline
    Wednesday, October 03 2018, 02:50 PM - #Permalink
    0
    Maybe you can tell me how to do it? and I can do it next time after an upgrade. Does that work?

    Are you going to fix the newer plugin?
    The reply is currently minimized Show
  • Accepted Answer

    Bastiaan.C
    Bastiaan.C
    Offline
    Wednesday, October 03 2018, 02:55 PM - #Permalink
    0
    I just found out that there is another problem:

    The Stripe pay now button shows in $ although the amount on the invoice is in €

    Please see attachment
    The reply is currently minimized Show
  • Accepted Answer

    Wednesday, October 03 2018, 02:56 PM - #Permalink
    0
    yes, this is what was fixed in the newer version. if you send me ftp access I can apply this fix (currency) on your 1.1.1 version
    The reply is currently minimized Show
  • Accepted Answer

    Bastiaan.C
    Bastiaan.C
    Offline
    Wednesday, October 03 2018, 02:58 PM - #Permalink
    0
    I asked you if you can give me the code so I can fix it myself?

    Please! ?

    Otherwise Can you please do the fixes and send me the 1.1.1 plugin per email. I have a hard time creating ftp addresses...

    Thanks so much!
    The reply is currently minimized Show
  • Accepted Answer

    Wednesday, October 03 2018, 03:00 PM - #Permalink
    0
    no, you can't do it yourself. I'll send you the plugin
    The reply is currently minimized Show
  • Accepted Answer

    Bastiaan.C
    Bastiaan.C
    Offline
    Wednesday, October 03 2018, 03:11 PM - #Permalink
    0
    Thanks for the plugin 1.1.2
    you told me that you would take out "The authorization code provided is not valid"
    It is still showing.

    Can you fix that?

    It seems to be working as it should :-)
    The reply is currently minimized Show
  • Accepted Answer

    Wednesday, October 03 2018, 03:12 PM - #Permalink
    0
    this is not from the plugin, this is from the component. I cannot take this out without actual FTP access, sorry.
    The reply is currently minimized Show
  • Accepted Answer

    Bastiaan.C
    Bastiaan.C
    Offline
    Wednesday, October 03 2018, 03:23 PM - #Permalink
    0
    For now I just changed it in the Language overwrite until you have fixed it :-)

    Can you tell us when you are working on solving this issue? for the latest plugin?
    The reply is currently minimized Show
  • Accepted Answer

    Bastiaan.C
    Bastiaan.C
    Offline
    Wednesday, October 03 2018, 04:46 PM - #Permalink
    0
    Can you tell us when you are working on solving this issue? for the latest plugin?
    The reply is currently minimized Show
  • Accepted Answer

    Bastiaan.C
    Bastiaan.C
    Offline
    Saturday, October 06 2018, 09:44 AM - #Permalink
    0
    Hello,

    Are you fixing this issue?
    Thank you
    The reply is currently minimized Show
  • Accepted Answer

    Wednesday, August 28 2019, 08:37 AM - #Permalink
    0
    Hi Germinal,
    Can I also have that file with that fix?
    Gracias
    • Germinal Camps
      more than a month ago
      what is exactly the problem you're having?
    The reply is currently minimized Show
  • Accepted Answer

    Thursday, August 29 2019, 10:35 AM - #Permalink
    0
    ricardo retuerto wrote:

    Hi Germinal,
    Can I also have that file with that fix?
    Gracias


    Message
    succeeded
    The authorization code provided is not valid
    Payment completed
    The reply is currently minimized Show
Your Reply